Discussion Forum for StarTeam Users

Win2000/VTS: Error starting VTS when logged in as non-admin

[ Follow Ups ] [ Post Followup ] [ Discussion Forum for StarTeam Users]

Posted by Kjell Rilbe on October 28, 2000 at 11:07:13:

I just installed Win2000 and StarTeam Build 4.2.699. I copied the config files from my old 4.2.685 installation under Win98.
To keep my OS & Program tree clean of files requiring regular backup I moved the config files to a separate folder and updated the windows registry key for config file location to point to that folder.
The datasources were also setup and verified. I tested all configurations - started VTS for each one, and closed them again.
All this was done when being logged in as Administrator.

Then I logged in as me, my user account. I tried to start VTS with one of the configurations. But now I get an error!
The error messgae I got was "Nyckelupps?tningen finns inte" ("The key set does not exist"?)
I hit "OK" in the error dialog and tried again. Now I got another error dialog:

Dialog caption: "Microsoft Visual C++ Runtime Library"
Dialog text:
Runtime Error!

Program: ...\StarBase\StarTeam VirtualTeam Server\StarTeamServer.exe

- pure virtual function call

When I hit "OK" in this error dialog, the VTS window vanishes (the program dies).

I tried this several times. I tried ODBC logging because the first message sounds like a DB error, but the errors occur before anything is written in the ODBC log.

Can anyone help me solve this?

Kjell Rilbe

Follow Ups:

Post a Followup




[ Follow Ups ] [ Post Followup ] [ Discussion Forum for StarTeam Users]